フォーラムの表示方法を少し変更しました。引き続きご利用ください。

Raspberry pi 4B と unbuntu20.04LTSについて | Raspberry Pi のアプリケーションについて | ラズパイダ フォーラム

フォーラム forum

このフォーラムへの投稿は登録制です。ユーザー登録をしてから書き込んでください。
読むだけであれば登録は必要ありません。

登録方法など初めてフォーラムをご利用の場合は以下のリンクをお読みください。

ラズパイダ フォーラムを設置しました
いつもサイトを訪れていただき誠にありがとうございます。...

ラズパイダ フォーラム

注意 ログイン後に一定時間の無操作であった場合はログアウトします。予めご了承ください。

シェア:
お知らせ
すべてクリアする

Raspberry pi 4B と unbuntu20.04LTSについて  

 

chiro
(@chiro)
Raspberry Pi 1A
参加しました: 6か月前
投稿: 4
2020年5月2日 6:54 PM  

皆様、初めまして。chiroと申します。

ラズバイダ、とても参考になり、読ませていただいております。ありがとうございます。

タイトルの件、ご経験されている方があればと思い、投稿させていただきます。

ラズバイダさんの記事を読ませていただき、ubuntu20.04LTSをインストールしてみました。

OSおよびMATEのインストールは問題なく終わり、update,upgradeも済ませ、

使用し始めたのですが、ラズパイの電源が勝手に切れる状況になってしまっています。

電源は3Aを利用していますし、放熱ケース利用し、冷却も出来ています。

更にOS上でも電源管理、ディスプレイ設定も、すべてなにもしないよう設定を変更しています。

この状態で、しばらく無負荷で放置していても、なにかブラウザで閲覧している最中でも、勝手にラズパイの赤LEDが切れ

ラズパイ自体が反応しなくなります…raspberianであれば、3日連続稼働させていても落ちません…

どなたか、同じようなご経験されている方おられませんでしょうか?

以上です。


引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 106
2020年5月2日 8:13 PM  

@chiro

ども。はじめまして。

もしかしたら、サスペンドとスクリーンセーバーの問題かも知れません。

良かったら添付画像のように、サスペンドさせないで、スクリーンセーバーは無しで設定してみてください。

タブン、スリープから復帰せずに落ちるのかな??と。(確証はありません。よく昔からLinuxではありました)

少なくても、こちらはそれで動いています。

 

もしくは、microSDカードの破損なら有り得るかも知れません。まぁ、起動しているならアレですけど、いつか起動しないことが出てくれば??と想像します。

あっ、upgradeで新たなバグってのも捨てきれませんが。


chiro いいね♪
返信引用
chiro
(@chiro)
Raspberry Pi 1A
参加しました: 6か月前
投稿: 4
2020年5月3日 9:38 AM  

@raspida-com

コメントをありがとうございます!

はい、お教えいただいた箇所は、すべてなしの設定にしております。

また、スリープも作業中に入ることはないかと思います…

すごいことに、なにか、ブラウジングしている最中であっても、

気が付くと落ちたり致します…

もうちょっと、OSのバージョンが上がるのを待ってみたいと思います。

ありがとうございました!

 


返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 106
2020年5月3日 9:45 AM  

@chiro

あら? 作業中に落ちるんですか?!

それは・・・OSも関係あるかも知れませんけど、ハード側っぽいですね。

 

良かったら試しに新品のmicroSDカード、それも容量が大きい物(64GBなど)を使ってトライしてみてください。

一応、うちのUbuntuMATEは問題無く動いています。

 

あっ、でもインストール後のupgradeはまだかけていません。

upgradeってバグが修正されることがほとんどですけど、新たなバグを産むこともあるので、しばらく様子をみてからアップしています。(※個人的にこれはRaspbianでもmacOSでも同じようにしています)

 

基板の不良もあるのですが、それはなかなか分かりませんからね・・・。

お力にならずにすみません。


chiro いいね♪
返信引用
chiro
(@chiro)
Raspberry Pi 1A
参加しました: 6か月前
投稿: 4
2020年5月3日 7:13 PM  

@raspida-com

コメントありがとうございます!

いまのところ、128GBのmicroSDを利用しております。

raspberianは、24時間以上なにしても落ちないので、ハードでもなさそうな気もしますが、

OSが使用するメモリー領域とかがちがうと、悪さするかもしれません…

不明なので、当該RPiは、raspberianで利用しようと思います。

いろいろありがとうございました!

 


返信引用
chiro
(@chiro)
Raspberry Pi 1A
参加しました: 6か月前
投稿: 4
2020年5月4日 3:52 PM  

追伸させていただきます。

頂いたコメントのなかで、update,upgradeされていないとのことでしたので。三度目の正直(二度、フルインストールしていたので…)一旦microSDをクリーンフォーマットしたあと、ゼロからインストールし、途中updateせずmateまでに設定完了させたところ、今のとこら全く落ちずに稼働しております。

ということは、なにかupdateする内容が不具合(update自体か、update後のmateとの相性なのか…)があるのかもしれません。 

ヒントをありがとうございました、

しばらく、この状態にて使ってみたいと思います。

取り急ぎお礼まで。


返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 106
2020年5月4日 5:35 PM  

@chiro

それはそれは良かったです。

updateではなく、upgradeはしばらく様子を見た方が良いでしょうね。

わざわざ、ご報告をありがとうございます。

 

現在だと、Ubuntu20.04とRaspberry Pi 4Bの組み合わせだと、電源周りのトラブルがあるかもよ?という参考になりました。

 


返信引用
Osamu
(@osamu)
Raspberry Pi 1A
参加しました: 10か月前
投稿: 15
2020年5月7日 7:01 AM  

私もをpi4+ubuntu18.04+MATEをメインで使っています。安定性抜群で、特に不満もないのでLTSが切れるまではこのままです。ubuntu20.04はSDにインストールして雰囲気を味わうことにします。


ラズパイダ いいね♪
返信引用
まきジャック
(@quad_diamonds)
Raspberry Pi 1A
参加しました: 1年前
投稿: 17
2020年5月10日 2:22 PM  

chiroさん

はじめまして。まきジャックです。私はrasbian busterで急に電源が落ちる不具合が先日ありました。NASとmagic mirror2(mm2)動かしている4Bの二台で発生しました。

色々調べた結果、二台とも原因は電源周りの不具合でした。NASは長期安定性を求めて供給電流が大きいノートPCと同じ大きさくらいACアダプター使用しているのですが掃除した時にアダプタからメガネケーブルがほんの少し抜けたようでソフトコネクト状態になっていたのが原因でした。もう一台のmm2は電源のUSBケーブルの端子内で破断しているようです。ケーブルの酷使が原因で新しいケーブル変えて不具合は発生しなくなりました。

また不具合が発生するようでしたら電源周りの不具合かもしれませんのでご確認ください。

 


ラズパイダ いいね♪
返信引用

お願い 登録時に入力されたパスワードはご自身で管理しください。

タイトルとURLをコピーしました