フォーラムの会員登録はメールを受信してパスワード設定です。

OMV 5.5.14-1 がHDD起動できない。 | Raspberry Pi のアプリケーションについて | ラズパイダ フォーラム

フォーラム forum

このフォーラムへの投稿は登録制です。ユーザー登録をしてから書き込んでください。
読むだけであれば登録は必要ありません。

登録方法など初めてフォーラムをご利用の場合は以下のリンクをお読みください。

ラズパイダ フォーラムを設置しました
いつもサイトを訪れていただき誠にありがとうございます。...
いつもサポートありがとうございます!
和歌山県白浜町の小型コンピュータ専門店「NewLifeNewDesing」ストアページはこちら
NewLife NewDesingは和歌山県白浜町の小型コンピュータ専門店

ラズパイダ フォーラム

注意 ログイン後に一定時間の無操作であった場合はログアウトします。予めご了承ください。

シェア:
お知らせ
すべてクリアする

OMV 5.5.14-1 がHDD起動できない。  

 

fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年10月30日 1:22 PM  

らずぱい4B 4GB を4台利用しています。3セットはHDD起動して、バックアップも取り、RAID1を2台でおこなって、OMVを動かしています。3残りの1セットも、開発用にOMVをHDD起動で動かしています。

で、一昨日ごろから、ネットでOMVをインストールしたら、HDD再起動が出来ずに、しばらく待っていると、ラズパイの画面に、

Cannot open access to?console, the root account is locked.

と出てしまいました。あ、OSはLiteではなく、デスクトップバージョンでOMVを動かしています。

今まで、何台も、さらに何回も、ネットインストールでOMVを入れてきましたが、HDDで起動できないだなんて、この5.5.14-1から初めてです。

ちなみに、SDカードにOMVをネットからインストールすると、何も問題なく使えます。

しかし、24時間使用には1年ぐらいしか耐えられないでしょうね。困った。困った。

ラズパイ用のOMVは、好きなバージョンを選べないですよね。

私は、どうしたらいいんでしょうか?Linux マシンへOMVを移植しなければいけないんでしょうか?

これって、OMVのインストーラーが悪さしていますよね?


引用
トピックのタグ
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月1日 3:51 PM  

書き込みありがとうございます。

んー、「ネットでOMVをインストールしたら」というのは、HDDで稼働しているOMVアップデートしたら?ってことですよね。

むかーし、Raspbianのバージョンアップ絡みでよくあったみたいです。

sudo nano /boot/cmdline.txt

で、rootのパスって合ってます?(〜root=PARTUUID=〜)

dist-upgradeなどのバージョンアップで、root =引数を正しく設定できなかった可能性がある

なんかデフォルトの指定になっている場合もそういうエラーで出るみたいです。

この事象が適合するなら、書き直せば立ち上がるような気がします。

起動しないのなら、別のRaspberry Piに繋げて中身を見るしかないですが。microSDカードと違ってHDDだからなー。

公式フォーラムのこれ、参考になりませんか?

https://www.raspberrypi.org/forums/viewtopic.php?t=204214

外れていたらすみません。

 

私もそういうアップデート時で困ったことあるんで、基本、アップデートやアップグレードしていません 🙂 だから、aptの場所が違うぞよ、というエラーが毎日届きますが・・・。

だいぶ経ってから更新しています。うちのRaspberry Pi3B+の簡易ファイルサーバーはmicroSDカードですけど、もう2年は問題なく動作していますから、そろそろヤバいかも知れませんね。4にしたのももう1年半は経過していますね。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月1日 6:32 PM  

@raspida-com

いつも、大変参考になっております。

>「ネットでOMVをインストールしたら」というのは、HDDで稼働しているOMVアップデートしたら?>ってことですよね。

残念ながらそうではないんです。

その方法で、すでにラズパイOS 非Lite版のBusterにて、HDD起動で動いているOMVは、

問題なく5.5.14-1へアップデートされ、動いています。

 

そうではなくて、困っているのは、新規購入したラズパイ4B 4GBの場合です。

別途ラズパイ4B 4Gを新規購入し、インストールを始めた場合です。

通常、新規に購入したラズパイは、手順の通り専用のmaicroSDカード64GBを、Windows上のRasberry Pi Imager でイレーズしてから、そのままImager で、一番上のRaspberry OS (32bit)を選択して書き込み、ベリファイも終了したSDカードを、Raspberry Pi 4B 4G 本体へ差し込み、電源を入れて起動し、日本語、UTF-8で設定で、全て自動で設定し、再起動させますよね。

この方法で、一通り、設定が間違っていないことを新規ラズパイで確認してから、そのSDカードに、OPMをターミナルからgithub経由で新規インストールしています。

wget -O -  https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install  | sudo bash

この段階では、OMV5.5.13までは、github経由でOMVを直接インストールしても、無線がこけたり、英文になったり足ますが、ローケール設定を直せば、何も問題なく動きます。

127.0.0.1でOMVにアクセス、あるいは、ip aでアドレスを調べてアクセすると、admin openmediavault でログインできて設定ができてました。

 

このSDカードの内容をSDカードコピヤを使って、HDD起動用のsdaなどにコピーし、

ラズパイ本体のEEPROMも、

vcgencmd bootloader_versiond

で調べて、最新のバージョンになっていることを確認

あるいは変更し、SDカードを抜いて、HDD起動が行われることを確認してきました。
OMV5.5.13バージョンまでは、この方法で全てうまくいってました。

ところが、先週の木曜日(10月29日)から、
新規購入ラズパイ4B(新品のラズパイ4Bが何台もあるので)にSDカードを
Rasberry Pi Imager でイレーズしてから、
OMVを wget -O - https://github.comでインストールすると、最後の再起動後、
SDカードで再起動され立ち上がりますが、
なんと、

(1)eth0:が無くなる(?)が、127.0.0.1でOMVへadminでアクセスは可能。

(2)この状態でOMVへの設定と、FTPやNAS(SMBA)は使用可能。

(3)OMVのバージョンは、5.5.14-1と表示される。

(4)このまま、HDDへSDカードコピヤを使ってSDカードの内容を、HDD(例えばsdaへ)コピーします。

(5)eepromのバージョンをvcgencmd bootloader_versionddで確認後SDカードを抜いて再起動すると、

いつまでたっても、HDDを認識ぜず立ち上がりません。

最後には、Cannot open access to?console, the root account is locked.

が出ます。

fstabを一切いじってもいないし、fstabのどこをどういじれば良いのかすらしりません。

github任せで、全自動でインストールしているだけです。

 

ラズパイだけは、OMVの古いインストーラーを選べないのですから、

本当に困ったものです。

SD起動のOMVインストールであっても、eth0:が変なものに変わってしまうのは、

やはり異常です。

 


返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月1日 10:42 PM  

@fatpigoh

なるほど。今回のバージョンからなんですね。

OMVのバージョン5.5.14-1などアップグレードでエラー報告がOMVのフォーラムに3つほど上がっていますね。

まだレスも付いていないくらい新しい話題でした。

https://forum.openmediavault.org/index.php?thread/36417-can-t-mount-disk-since-omv-5-update-unable-to-read-filesystem/

どれもfstabに関連するものなので、条件によってはバグが出る様子ですね。

githubのissueにも似たようなこと書いてありますし、実は私も以前からHDDがアンマウントした後に削除できなくなっています。(取り外した後なので放置していますけど)

OMV5からインストールは一旦、Raspbian(Raspberry Pi OS Lite)を入れてからになりましたけど、Lite版ではない通常版なのは理由があるのでしょうか。

私は試していませんが、一応導入方法PDFには、32bit版のLite版を入れてと注意がまだ掲載されています。

https://github.com/OpenMediaVault-Plugin-Developers/docs/blob/master/Adden-B-Installing_OMV5_on_an%20R-PI.pdf

更新されていないPDFといえばそれまでですけどね。

64bit版ではないとは思いますが、Lite版は通常版とも違って結構色々とライブラリも入っていません。通常版を使った場合、何かと影響があるんではないでしょうか??

HDDのデータなどを待避しなくても良いなら、一度、Lite版でセットアップしてみてはどうでしょう?

または公式サイトで事象が再現されてアップデートされれば行くんですけどね。

ラズパイだけは、OMVの古いインストーラーを選べないのですから、

本当に困ったものです。

ええ、それは確かにそうですね。
まぁ、無料で使えるので私など非エンジニアは文句も言えないですね 😣 

 

あ、投稿のcodeタグだけ修正させていただきました。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月2日 7:55 AM  

今から、通常版を試してみますね。Liteは、やったことが無いので、自信がないですが。

駄目だったら、SDカード起動で様子を見ます。


ラズパイダ いいね♪
返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月2日 1:44 PM  

ええ、Lite版ですよ。

それでもダメだった場合は致命的なバグでしょうか。

Lite版も同じように、起動させてからgithubでOMVをインストールすればOKです。

ただ、USBのHDDやSSDへの移行は、Lite版だとGUI アプリである公式のSD Card Copierは、入っていませんし、単体で入れても起動できません。

コマンドでコピーは、DDコマンドで、現在のシステム領域をコピーしてあげれば公式のSD Card Copierと同じになるかな、とは思います。(試していません)

/dev/mmcblk0 (システム領域?)

/dev/sda (繋いだSSDやHDDのパーティション?)

その上で、raspi-configの中のメニューから同じように起動をUSB接続のSSDやHDDに変更して再起動すれば、立ち上がるとは思います。

SDカードのコピーについて、GUIでやるには、やはりデスクトップ環境を入れないとなりませんから、それだとバグ?回避にはならないかも知れません。

microSDカードでの運用であれば、Lite版にgithubからインストで終わりますね。

 

ハッキリとしたバグ発生条件がOMV側が認識すれば、すぐに修正されると思うので悩ましいですね。


返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月2日 1:57 PM  

@fatpigoh

CUIでコマンドなら、「rpi-clone」でもコピーできると思います。

rpi-cloneはgitでインストールできます。

https://github.com/billw2/rpi-clone

以下、書き込みがコピーではビンゴだと思います。
https://github.com/billw2/rpi-clone/issues/98#issuecomment-646887605

For SD card to USB boot there are several ways to go so I'll show some examples that maybe will cover your cases:

You have an SD card booting on the Pi 4 and want to make it USB bootable:

For safety, make a pure SD backup. With an SD card in a USB card reader at sdb:
rpi-clone sdb
Now make your working SD card boot to a USB disk at sda. Clone to the sda with -l option:
rpi-clone -l sda
Reboot and the SD card will transfer the booting to the USB disk. After boot, the SD card is not in use and the root will be on sda2 and /boot will be sda1

3a) With the USB disk booted, clone only the root back to the SD card still in mmcblk0:
rpi-clone -m / mmcblk0
3b) or better, especially if you have apt upgraded while running of USB, clone both root and /boot back to the SD card, but preserve the SD card to USB boot setup (again use -l option):
rpi-clone -l mmcblk0

If you upgrade and rpi-eeprom version has USB booting built in, do a rpi-clone as in 3b) so the SD card will have the new eeprom files. Use the -l option!!! Now reboot letting the SD card do the boot to USB. This should update the eeprom so you no longer need the SD card to boot. So, pull it out and reboot.

With native USB booting working, you no longer need to use the -l option when cloning from SD card to USB or USB to SD.

The GPT error is from the parted command and I would need more debug info to know why you get that. Is the USB 3 HD huge? Maybe a partition sizing problem. The -f copies the partition table and that could be incompatible. In that case you would need to manually partition the USB 3 HD and not use the -f option. See the examples for manually partitioning.

 


返信引用
まきジャック
(@maki_jack)
Raspberry Pi 2B
参加しました: 1年前
投稿: 20
2020年11月2日 11:25 PM  

>fatpigoh-san

 どうも!まきジャックです。新しいVer試していないので違うかもしれませんがマニュアルのP.15の下記のコマンドは実施されましまでしょうか?

sudo rm -f /etc/systemd/network/99-default.link


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月3日 8:22 AM  

>まきジャックさん

情報を、ありがとうございます。そういえば、最近マニュアル読んでなかったですねー。マニュアルを調べてみますね。それからやってみます。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月3日 9:53 AM  

まきジャックさん

えーと、どこの、どのドキュメントの15ページなのかわかりませんが、このコマンドをググってみると、ラズパイ4のネットワークが、OMVのインストールスクリプトによって壊れた場合の復旧用のようです。

実行してみましたが、効果がありませんでした。

BusterのLite以外のデスクトップタイプで、SD起動であれば、OMV5.5.14-1以前のバージョンは、Busterでも127.0.0.1でadmin openmediavaultでログインして、インターフェースを強制的に変更すれば、ディスプレーでは、罰点がでたままですが、有線のeth0:も、無線LANのwlan0:も普通に使えました。

ところが、OMV5.5.14-1からは、eth0:が見たこともないような名前に代わっていて、なぜか無線LANの次のアドレス番号がふられています。そのIPをたたけば、GUI設定が出来ますが、実験ならこれでもいいのですが。そのまま仕事用の需要なサーバーとして使う気は、致しませんねえ。

てな感じです。


返信引用
まきジャック
(@maki_jack)
Raspberry Pi 2B
参加しました: 1年前
投稿: 20
2020年11月3日 10:56 AM  

>fatpigoh-san

ラズパイダさんがリンク貼ってくださっている下記のマニュアルです。

https://github.com/OpenMediaVault-Plugin-Developers/docs/blob/master/Adden-B-Installing_OMV5_on_an%20R-PI.pdf

99-default.linkを消せばeth0に戻るかなぁと思ったのですが違いましたか。失礼しました。最近のLinux のネットワークインターフェースはeth0でなくenp1s0などに変わっちゃているのでハマったことがありました。Ubuntu18.04環境でgrubにkernelパラメータ渡してeth0に戻したのですがラズパイOSでのやり方わからないです。お役に立てずすいません。


ラズパイダ いいね♪
返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月3日 1:28 PM  

一応、Raspberry Pi4 B 4GB で、Buster Lite でHDD起動ができるかを試しました。

これは、何も問題なく、HDD起動しました。

さあ、このBuster Lite のHDDにOMV5をインストールしてちゃんと起動できればいいのですが。。度でしょうか?


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月3日 2:22 PM  

いやー。残念。Buster Lite でも、USB-HDDにOMV5をインストールすると、その後はHDD起動が途中で止まってしまいます。同様なメッセージ

Cannot open access to console, the root account is locked.

になってしまいます。症状は Buster Desktopと同じですが、Liteは途中の経過が読み取れますね。

ずらずらと[ OK ]が続いて、

[ OK ] Started Wait for Network to be Configured.

[ TIME(赤) ] Timed out waiting for device /dev/disk/by-partuuid/f1c5b824-01.

[DEPEND(黄) ] Dependency faild for File System Check on /dev/disk/by-partuuid/f1c5b824-01.

[DEPEND(黄) ] Dependency faild for /boot.

[DEPEND(黄) ] Dependency faild for Local File Systems.

[ OK ] が30個ぐらい続いて

You are in emagency mode. ~

Cannot open access to console, the root account is locked.

と出て、止まっています。

 

残念でした。。しばらく、ラズパイや、OMVのアップデートが出るのを待ちますね。とほほ。SDカードで起動で、24時間運用です。。


ラズパイダ いいね♪
返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月3日 7:33 PM  

@fatpigoh

お疲れ様でした! 😑 

やはりバグですね。Lite版だと確かにエラーが読み取れますね。

rpi-cloneの説明にもあったようにブートローダー?もコピーしないとデータだけだとダメです。

rpi-cloneだと引数付けなくてもいけるみたいです。

で、ラズパイ公式側のraspi-configでブートを変えてあげれば・・・なんですけど、OMV5自体のバグなら仕方ありません。先日のRaspberry Pi OSのraspi-configバージョンアップで何かが変わったのでしょうか。

>まきジャックさん

フォロー、ありがとうございます。enp1s0ってCentOS、Redhat、Ubuntuだけではなく新しいのは全部そうなっている? 命名規則らしいですけど、この辺が難しいですよね。私はエンジニアではないので、そりゃもう、ちんぷんかんぷん。

また、気がついたら書き込みください。

 

 


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月4日 7:48 AM  

>まきジャックさん

色々ここで、ラズパイとOMVについてお話しできることが、本当に救いになります。OMV本家のフォーラムにも投稿は英語でしているのですが、フォーラムそのものが面倒な仕組みで、厄介ですし、反応も今のところありません。投稿の仕方が間違っているのかもしれません。。

いずれにしても、ラズパイダさんや、まきジャックさんとお話しできることが、私の気持ちの救いです。

いろんな意味でありがとうございます。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月4日 8:11 AM  

もう一度、SDカード起動状態で、OMV 5.5.14-1をインストールしてみました。

LANの表示が罰点にこけて、英語表示になりますが、これは今までと同じで、

OMVへ127.0.0.1で亜癖うs出来ますし、や、コマンド ip a でeth0:がこけていないので、

GUIでOMV側から強制的に設定してしまえば、何も問題なく使えますね。以前のバージョンと同じです。

 

 

SDカードをOMVなしで設定して、HDDへ rpi-cloneや、SDカードコピヤでこぴーすれば、らずぱいOS Busterは問題なくHDD起動をいたします。

このHDD起動したHDDへ、OMVをインストールしたり、SDカード上でOMVをインストールして、HDDへコピーすると、やはりHDD起動が出来なくなります。

ラズパイのOSがSDカード上でOS自身と、OMV自身のアプリケーションの定義部分を担っているので、24時間使用は1から2年でSDカードの寿命が切れる恐怖に、怯えなくてはならないのは致し方ないのですが。。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月5日 11:06 AM  

今朝、SD起動のOMVをアップデートチェックしたら、5.5.14-1から5.5.15-1にアップデートされました。

openmediavault (5.5.15-1) stable; urgency=low

* Adapt Avahi configuration to latest changes in Debian.
* Rename environment variable OMV_POSTFIX_MAIN_MAILBOX_SIZE_LIMIT to
OMV_POSTFIX_MAIN_MESSAGE_SIZE_LIMIT.
* Cleanup SMB/CIFS 'vfs objects' configuration.

 

とのことですが、さーてはたして、HDD起動のラズパイにOMV5.5.15-1をインストールして、無事に動くのでしょうか?確かめてみます。


返信引用
fatpigoh
(@fatpigoh)
Raspberry Pi 1A
参加しました: 9か月前
投稿: 14
2020年11月5日 12:06 PM  

残念ながら、5.5.15-1も、駄目でした。HDD起動の件については、まだ、気が付いていない模様です。うーむ。同じ症状が出ます。OMVをいんすとーるすると、ラズパイOSがHDDから立ち上がらなくなります。


返信引用
ラズパイダ
(@raspida-com)
エバンジェリスト
参加しました: 3年前
投稿: 121
2020年11月6日 1:50 PM  

@fatpigoh

貴重な体験談をありがとうございます。

OMV(OpenMediaVault)は、かなり高機能ですから色々と不具合は残っていますね。

それにmicroSDカードでの起動がメインになっています。Raspberry Pi OSが対応したSSDやHDDでの起動に重点を置くのはもう少し先かも知れません。

基本的な使い方なら快適です。

OMVに限らず、Raspberry Piはあくまでも実験的な意味合いが強いと思います。高価な既製品と同等にはなりませんけど、個人・小規模利用には十分な性能だと思っています。

ひとまず、NASとしてOMVを使う場合、現行バージョンではmicroSDカードでの起動で、データを大容量HDDへ置く使い方はバージョンアップしても大丈夫ってことですね。

まぁ、同じようにHDD起動でコケている人が多くなれば直ぐに解決されるような気もします。待ちましょう。


返信引用

お願い 登録時に入力されたパスワードはご自身で管理しください。

タイトルとURLをコピーしました